Order confirmation not being sent
Incident Report for Abicart
Resolved
This incident has been resolved.
Posted Sep 29, 2020 - 05:50 CEST
Investigating
We are currently investigating this issue.
Posted Sep 28, 2020 - 21:03 CEST
This incident affected: Abicart - Email system.